Unicorn Nginx Issue

Matt Mongeau halogenandtoast at gmail.com
Tue Oct 13 12:57:21 EDT 2009

I've setup nginx with this
server {
  listen 80;
  server_name unicorn.local;
  location / {
    proxy_pass http://unicorn;
upstream unicorn {
  server unix:/Users/mattmongeau/projects/test/unicorn/tmp/sockets/unicorn.sock;

When I run unicorn_rails -c config/unicorn.rb -E development I can
access the application just fine on unicorn.local

When I run unicorn_rails -c config/unicorn.rb -E development -D I get this issue

2009/10/13 12:34:22 [error] 1007#0: *62 connect() to
unix:/Users/user/projects/test/unicorn/tmp/sockets/unicorn.sock failed
(61: Connection refused) while connecting to upstream, client:, server: unicorn.local, request: "GET / HTTP/1.1", upstream:
host: "unicorn.local"

ps -aux shows that the workers are created
and ls -la show srwxrwxrwx  1 mattmongeau  staff    0 Oct 13 12:51 unicorn.sock=

Any suggestions on what I am doing wrong. I running OSX 10.6.1, with
nginx installed from passenger (nginx version: nginx/0.6.37)

Thanks, Matt

More information about the mongrel-unicorn mailing list