[Mongrel-development] OldRails Rack handler added to Unicorn

Eric Wong normalperson at yhbt.net
Mon Mar 23 17:57:00 EDT 2009


Hi all,

I've committed support to Unicorn for old versions of Rails that didn't
support Rack.  I think it could be useful for Mongrel 2 (or any other
server) as well:

  http://git.bogomips.org/cgit/unicorn.git/commit/?id=0b095ea72 [1]

  or just fetch/clone git://git.bogomips.org/unicorn.git

The bin/unicorn_rails code is itself a mess, but cleaning it up is on my
ever growing TODO list along with writing automated tests for them.

It actually seems Rails 2.2.0+ could be Racked, but only 2.3+ requires
Rack. (I'll actually try to read the changelogs at some point but the
long lines are driving me nuts).

I'll probably test some ancient Rails apps I have lying around
on them later this week, but I did manage to start and run an
ancient Rails 1.2.3 app I had lying around with Unicorn and it
appeared to run fine (static file serving and all).

[1] - in case that short URL ever becomes ambiguous:

  http://git.bogomips.org/cgit/unicorn.git/commit/?id=0b095ea72fb849682a1185a626eef247b5afc1cd

-- 
Eric Wong


More information about the Mongrel-development mailing list