[Mongrel-development] Mongrel for 1.9, for real?

Luis Lavena luislavena at gmail.com
Tue Jul 7 20:06:32 EDT 2009

On Tue, Jul 7, 2009 at 8:51 PM, Evan Weaver<evan at cloudbur.st> wrote:
> http://github.com/fauna/mongrel/tree/spinoff
> Ragel 6.5 builds, and tests pass on 1.8 and 1.9, except for:
> test_deflate(HandlersTest):
> Zlib::DataError: incorrect header check
>    /Volumes/Projects/fauna/mongrel/test/test_handlers.rb:109:in
> `block in test_deflate'
> Which I don't understand right now.

Me neither, since tested manually Zlib at IRB and the deflating worked
without the header.

> Go nuts with the packaging; I'm still not sure what you're trying to
> accomplish exactly.

I'm trying to simplify the building and release of new gems. MinGW
didn't work with 1.1.5 and catching up and build new releases for
Mongrel got stuck in 2007/08.

What I'm trying: allow mongrel "run" on 1.9, next version (1.2 or 2.0)
can go nuts and do Rack and proper threading on 1.9...

Right now, we just need it to "work".

Luis Lavena
Perfection in design is achieved not when there is nothing more to add,
but rather when there is nothing more to take away.
Antoine de Saint-Exupéry

More information about the Mongrel-development mailing list