[Mongrel-development] Mongrel for 1.9, for real?

Evan Weaver evan at cloudbur.st
Tue Jul 7 19:51:57 EDT 2009


http://github.com/fauna/mongrel/tree/spinoff

Ragel 6.5 builds, and tests pass on 1.8 and 1.9, except for:

test_deflate(HandlersTest):
Zlib::DataError: incorrect header check
    /Volumes/Projects/fauna/mongrel/test/test_handlers.rb:109:in
`block in test_deflate'

Which I don't understand right now.

Go nuts with the packaging; I'm still not sure what you're trying to
accomplish exactly.

Evan

On Sun, Jun 28, 2009 at 11:26 PM, Luis Lavena<luislavena at gmail.com> wrote:
> On Mon, Jun 29, 2009 at 2:41 AM, Evan Weaver<evan at cloudbur.st> wrote:
>> Ugh, sorry. Mongrel is not dead, but rather severely neglected by me.
>>
>
> And me. Been focusing a lot on RubyInstaller and the related tools.
>
>> We still use it at Twitter, for what it's worth. I will gather up the
>> 1.9 bits I have and send you the details.
>>
>
> Cool, you know my email already ;-)
>
>> What cross-compilation strategy did you want to use for MinGW?
>>
>
> rake-compiler and fat binaries:
>
> http://github.com/luislavena/rake-compiler/tree/
>
> Cheers,
> --
> Luis Lavena
> AREA 17
> -
> Perfection in design is achieved not when there is nothing more to add,
> but rather when there is nothing more to take away.
> Antoine de Saint-Exupéry
> _______________________________________________
> Mongrel-development mailing list
> Mongrel-development at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-development
>



-- 
Evan Weaver


More information about the Mongrel-development mailing list