[Mongrel-development] 1.9

Evan Weaver evan at cloudbur.st
Tue Dec 11 13:43:20 EST 2007


Mongrel will probably run with minor changes on 1.9. It will
definitely not run well, because (like Kirk says) having a
process-level thread queue will destroy your performance under load in
short order.

It would be nice to move to something simple and eventy, like just
select() polling maybe. No dependencies.

Evan

On Dec 11, 2007 1:39 PM, Filipe <filipe at icewall.org> wrote:
> On Tue, 11 Dec 2007, Evan Weaver wrote:
>
> > So there will be two different stable Rubys, and everyone has to be
> > compatible with both of them? Ugh.
>
> Yeap, kind of. Did anyone here try to run mongrel with ruby 1.9? I
> already played with ruby1.9 for a while migrating debian packages, so I
> would be interested in help with this 'port'.
>
> >>
> >> It will take time to update for 1.9, but the sooner the better.
> >>
>
> Yeah.... u are right.
>
> Cheers,
>
> filipe {
>   @             icewall.org
>   GPG        1024D/A6BA423E
>   Jabber  lautert at jabber.ru
>
> }
>
>
> _______________________________________________
> Mongrel-development mailing list
> Mongrel-development at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mongrel-development
>



-- 
Evan Weaver
Cloudburst, LLC


More information about the Mongrel-development mailing list