[mocha-developer] Beyond multiple return values
jamesmead44 at gmail.com
Mon Mar 12 06:46:00 EDT 2007
On 12/03/07, James Moore <jamesthepiper at gmail.com> wrote:
> On 3/9/07, James Mead <jamesmead44 at gmail.com> wrote:
> > Adding raises() to TestObject seems a bit intrusive.
> > >
> > In what way do you think it would be intrusive?
> It's adding a method to another, basically unrelated, class object just to
> change the readability of mocks. It seems goofy to add a method to a
> where the new method has little or no interaction with the class it
> - James Moore
I agree it's not very object-oriented, but I'd be happy to sacrifice this
for readability. Readability is very important to me.
Thanks for responding - it helps to know why you think it would be
More information about the mocha-developer