[mocha-developer] Fwd: [ mocha-Patches-16424 ] Ruby 1.9 Compatibility

James Mead jamesmead44 at gmail.com
Thu Dec 20 10:51:53 EST 2007


---------- Forwarded message ----------
From: noreply at rubyforge.org <noreply at rubyforge.org>
Date: 20 Dec 2007 15:48
Subject: [ mocha-Patches-16424 ] Ruby 1.9 Compatibility
To: noreply at rubyforge.org


Patches item #16424, was opened at 2007-12-19 02:43
You can respond by visiting:
http://rubyforge.org/tracker/?func=detail&atid=7479&aid=16424&group_id=1917

Category: None
Group: None
Status: Open
Resolution: None
Priority: 3
Submitted By: Joshua Peek (joshpeek)
Assigned to: Nobody (None)
Summary: Ruby 1.9 Compatibility

Initial Comment:
Ruby 1.9 Compatibility



Tested on

* ruby 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]

* ruby 1.9.0 (2007-12-11 patchlevel 0) [i686-darwin9.1.0]





----------------------------------------------------------------------

>Comment By: James Mead (jamesmead)
Date: 2007-12-20 15:48

Message:
Thanks for your help. I've tested and applied your patch and fixed a
few other warnings in revision 206 of trunk.



Cheers, James.

----------------------------------------------------------------------

You can respond by visiting:
http://rubyforge.org/tracker/?func=detail&atid=7479&aid=16424&group_id=1917


As of revision 206, thanks to Joshua Peek, trunk should be Ruby 1.9
compatible. Please let us know if you run into any problems. I can see
some opportunities for simplifying some of the implementation e.g.
using the new BasicObject class, but that can wait for now.

-- 
James.
http://blog.floehopper.org
http://tumble.floehopper.org


More information about the mocha-developer mailing list