[mocha-developer] small suggestion - once method on Expectation

Kevin Clark kevin.clark at gmail.com
Tue Apr 3 14:33:13 EDT 2007

I find myself using .once here and there by accident. It'd be nice to have :)
exactly_once work work too

On 4/3/07, James Mead <jamesmead44 at gmail.com> wrote:
> David is right.
> I have occasionally thought about adding an "exactly_once" method for
> readability/emphasis.
> Is this what you have in mind? Or was it not clear from the documentation
> that the default was to expect a call exactly once?
> It would be good to have your feedback.
> --
> James.
> http://blog.floehopper.org
> _______________________________________________
> mocha-developer mailing list
> mocha-developer at rubyforge.org
> http://rubyforge.org/mailman/listinfo/mocha-developer

Kevin Clark

More information about the mocha-developer mailing list