[mocha-developer] New to Mocha

James Mead jamesmead44 at gmail.com
Mon Oct 23 05:18:13 EDT 2006


On 18/10/06, Michael Lee <yfl at bund.com.au> wrote:
>
> Hi all
>
> I am new to Mocha. I am trying to use it for my pet rails project.
>
> I seem to be getting loads of errors when I add mocha as a plugin. It
> seems to be conflicting with TinyMCE plugin http://johnwulff.com/
> articles/2006/05/31/tinymce-with-ruby-on-rails
>
> I am getting the following errors
>
> ActionView::TemplateError: undefined method `using_tiny_mce?' for
> #<#<Class:0x316af20>:0x312adbc>
>      On line #5 of app/views/layouts/admin.rhtml
>
>      2:   <head>
>      3:          <% # Include TinyMCE before other JS to avoid
> problems -%>
>      4:     <%= javascript_include_tag "tiny_mce/tiny_mce" %>
>      5:     <%= tiny_mce if using_tiny_mce? %>
>      6:          <%= render :partial => 'layouts/head' %>
>      7:          <%= stylesheet_link_tag 'raid' %>
>      8:
>
>
> Seems like tinymce is not loading up properly when mocha is around :(
>
> Help pls
>
> Regards
>
> Michael Lee
> Thoughtworks


Hi Michael,

Sorry not to respond sooner - I've been away on holiday and your email has
been sitting in the moderation queue because you haven't subscribed to the
mailing list.

I've returned to a big list of things to do, so not sure I'm going to get
round to installing the tiny mce plugin. I assume your error comes and goes
when you install/uninstall Mocha? Are you installing Mocha as a Rails
plugin? Are you using HEAD?

Is there any way you can narrow the scope of the problem to a simple failing
test case?

Cheers,
-- 
James.
http://blog.floehopper.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/mocha-developer/attachments/20061023/0e0a5fb7/attachment.html 


More information about the mocha-developer mailing list