[mocha-developer] how to install from svn?

hemant gethemant at gmail.com
Fri Dec 15 10:54:01 EST 2006

When trying to run Chris samples I get error:

uninitialized constant Test (NameError)
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
        from /usr/lib/ruby/gems/1.8/gems/mocha-0.3.2/lib/mocha.rb:1
        from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:33:in
        from spam_cannon_test.rb:2

So i figure there might be some problem with the mocha gem and its
dependency upon Test::Unit, so I tried installing from SVN, but there
doesn't seems to be a install/setup.rb there.

All, thats is there is, init.rb, which is for rails plugin.

I am trying to use mocha for testing a three tier networking app. That
accepts connections from clients, and in turn requests some external
servers and returns back the data to the client. In between it does,
some caching, session validation and stuff.

I am having a hard time, unit testing this app, so though I can give mocha spin.

There was only one Road; that it was like a great river: its springs
were at every doorstep, and every path was its tributary.

More information about the mocha-developer mailing list