[libxml-devel] [ libxml-Bugs-21895 ] [Docs] require 'libxml'

noreply at rubyforge.org noreply at rubyforge.org
Sat Nov 15 20:02:36 EST 2008


Bugs item #21895, was opened at 2008-09-10 01:03
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1971&aid=21895&group_id=494

Category: None
Group: None
>Status: Closed
>Resolution: Accepted
Priority: 3
Submitted By: Thomas Peklak (thomaspeklak)
Assigned to: Nobody (None)
>Summary: [Docs] require 'libxml' 

Initial Comment:
The README is misleading as the code samples say to use "require 'libxml'" which does not work when you do not include LibXML, too.

I found in the comments of libxml.rb to use require 'xml' instead, see below

# DEPRECATED: Use require 'xml' instead!
#
# include LibXML

Please correct this, because the README is the first thing people look for code samples

----------------------------------------------------------------------

>Comment By: Charlie Savage (cfis)
Date: 2008-11-15 18:02

Message:
Hi Thomas,

I just looked at libxml.rb:


require 'libxml.rb'

include LibXML

This seems correct.  So it looks like this issue has been fixed.  Thanks for the report.
So, this should be fine.  Maybe you 

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1971&aid=21895&group_id=494


More information about the libxml-devel mailing list