[libxml-devel] [ libxml-Bugs-22336 ] "property" method not recognised on LibXML::XML::Node

noreply at rubyforge.org noreply at rubyforge.org
Sat Nov 15 19:43:57 EST 2008


Bugs item #22336, was opened at 2008-10-08 04:24
You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1971&aid=22336&group_id=494

Category: General
Group: None
>Status: Closed
Resolution: None
Priority: 3
Submitted By: Rob Lucas (roblucas)
>Assigned to: Charlie Savage (cfis)
>Summary: "property" method not recognised on LibXML::XML::Node

Initial Comment:
My hard disk recently died so I had to do a fresh install of all my gems including libxml-ruby (I installed 0.8.3). I can't get the old version number, as the hard disk really is dead, but it was probably 0.5.? . This new install broke some previously fine libxml-ruby based code: 

- Now, any use of node.property("name") (e.g. model.property("name")) produces an error like:

undefined method `property' for <model name="Any"/>:LibXML::XML::Node

- However, changing these calls to the node["name"] format (in this case model["name"]) fixes the problem

node.property("name") still appears to be valid in the API docs, and I can't find any indication that it has been deprecated or anything.

----------------------------------------------------------------------

>Comment By: Charlie Savage (cfis)
Date: 2008-11-15 17:43

Message:
Hi Rob, 

Yes node#property has been deprecated.  However, it should not have been removed from libxml.  So its back in (will be in next release), but will show a warning message.  The correct fix is node["foo"] like you noticed.

Thanks for the report.

----------------------------------------------------------------------

You can respond by visiting: 
http://rubyforge.org/tracker/?func=detail&atid=1971&aid=22336&group_id=494


More information about the libxml-devel mailing list