<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:x="urn:schemas-microsoft-com:office:excel" xmlns:p="urn:schemas-microsoft-com:office:powerpoint" xmlns:a="urn:schemas-microsoft-com:office:access" xmlns:dt="uuid:C2F41010-65B3-11d1-A29F-00AA00C14882" xmlns:s="uuid:BDC6E3F0-6DA3-11d1-A2A3-00AA00C14882" xmlns:rs="urn:schemas-microsoft-com:rowset" xmlns:z="#RowsetSchema" xmlns:b="urn:schemas-microsoft-com:office:publisher" xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet" xmlns:c="urn:schemas-microsoft-com:office:component:spreadsheet" xmlns:oa="urn:schemas-microsoft-com:office:activation" xmlns:html="http://www.w3.org/TR/REC-html40" xmlns:q="http://schemas.xmlsoap.org/soap/envelope/" xmlns:D="DAV:" xmlns:x2="http://schemas.microsoft.com/office/excel/2003/xml" xmlns:ois="http://schemas.microsoft.com/sharepoint/soap/ois/" xmlns:dir="http://schemas.microsoft.com/sharepoint/soap/directory/" xmlns:ds="http://www.w3.org/2000/09/xmldsig#" xmlns:dsp="http://schemas.microsoft.com/sharepoint/dsp" xmlns:udc="http://schemas.microsoft.com/data/udc" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:sub="http://schemas.microsoft.com/sharepoint/soap/2002/1/alerts/" xmlns:ec="http://www.w3.org/2001/04/xmlenc#" xmlns:sp="http://schemas.microsoft.com/sharepoint/" xmlns:sps="http://schemas.microsoft.com/sharepoint/soap/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:udcxf="http://schemas.microsoft.com/data/udc/xmlfile" xmlns:wf="http://schemas.microsoft.com/sharepoint/soap/workflow/" xmlns:mver="http://schemas.openxmlformats.org/markup-compatibility/2006" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns:mrels="http://schemas.openxmlformats.org/package/2006/relationships" xmlns:ex12t="http://schemas.microsoft.com/exchange/services/2006/types" xmlns:ex12m="http://schemas.microsoft.com/exchange/services/2006/messages" xmlns:Z="urn:schemas-microsoft-com:" xmlns="http://www.w3.org/TR/REC-html40">

<head>
<meta http-equiv=Content-Type content="text/html; charset=us-ascii">
<meta name=Generator content="Microsoft Word 12 (filtered medium)">
<style>
<!--
 /* Font Definitions */
 @font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
        {font-family:Tahoma;
        panose-1:2 11 6 4 3 5 4 4 2 4;}
 /* Style Definitions */
 p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:12.0pt;
        font-family:"Times New Roman","serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-reply;
        font-family:"Calibri","sans-serif";
        color:#1F497D;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-size:10.0pt;}
@page Section1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
        {page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
 <o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
 <o:shapelayout v:ext="edit">
  <o:idmap v:ext="edit" data="1" />
 </o:shapelayout></xml><![endif]-->
</head>

<body lang=EN-US link=blue vlink=purple style='word-wrap: break-word;
-webkit-nbsp-mode: space;-webkit-line-break: after-white-space'>

<div class=Section1>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>I see. The problem is that an application that is written in a
scripting language is not treated the same as a compiled .exe file in CLR&#8217;s
assembly loading mechanism. Executable file defines a directory from whose
subdirectories could private assemblies be loaded. Since we have no .exe file
for Ruby apps CLR loader doesn&#8217;t consider the root of the app during the
search for an assembly.<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>I&#8217;ll add support for loading from .dlls back. Framework
assemblies should still be loaded either using Kernel#require(&lt;long assembly
name&gt;).<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'>Tomas<o:p></o:p></span></p>

<p class=MsoNormal><span style='font-size:11.0pt;font-family:"Calibri","sans-serif";
color:#1F497D'><o:p>&nbsp;</o:p></span></p>

<div>

<div style='border:none;border-top:solid #B5C4DF 1.0pt;padding:3.0pt 0in 0in 0in'>

<p class=MsoNormal><b><span style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>From:</span></b><span
style='font-size:10.0pt;font-family:"Tahoma","sans-serif"'>
ironruby-core-bounces@rubyforge.org
[mailto:ironruby-core-bounces@rubyforge.org] <b>On Behalf Of </b>Ivan Porto
Carrero<br>
<b>Sent:</b> Tuesday, May 13, 2008 6:50 PM<br>
<b>To:</b> ironruby-core@rubyforge.org<br>
<b>Subject:</b> Re: [Ironruby-core] r105 broke assembly loading<o:p></o:p></span></p>

</div>

</div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

<div>

<p class=MsoNormal>That also isn't working for me.&nbsp;<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal>If I use /paths:full path here or -I &quot;full path
here&quot; it still doesn't let me require that assembly .<o:p></o:p></p>

</div>

<div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

<div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

<div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

<div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

<div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

<div>

<div>

<p class=MsoNormal>On 14/05/2008, at 1:27 PM, Steve Eichert wrote:<o:p></o:p></p>

</div>

<p class=MsoNormal><br>
<br>
<o:p></o:p></p>

<p class=MsoNormal style='margin-bottom:12.0pt'>I haven't tried revision 105 to
know if it still works but I've been using the /paths command line option to
tell IronRuby where my assemblies are.<br>
<br>
ir.exe paths/:C:\paths\to\my\dlls my_ruby_script.rb<br>
<br>
Cheers,<br>
Steve<o:p></o:p></p>

<div>

<p class=MsoNormal>On Tue, May 13, 2008 at 9:17 PM, Ivan Porto Carrero &lt;<a
href="mailto:ivan@flanders.co.nz">ivan@flanders.co.nz</a>&gt; wrote:<o:p></o:p></p>

<p class=MsoNormal>Ok I'm all for features but how do I now require my own
homebaked dll because registering them in the GAC isn't the way to go IMHO :)<br>
<br>
I've tried a bunch of things to get to my dll but it boils down to that it
doesn't know how to load it. When I copy my assembly into the ironruby build
folder it does work. That just doesn't seem right to me. If there is a new an
elegant way to load arbitrary assemblies then I'd love to know. In meantime I
can hack my source to add assembly loading from a path as well<br>
<br>
Below the output from my various tries to get my assembly loaded without
putting it in the ironruby binaries folder<o:p></o:p></p>

<div>

<p class=MsoNormal><br>
<br>
+ C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby<o:p></o:p></p>

</div>

<p class=MsoNormal>&raquo; ir -I
C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby\bin\Sylvester.Contracts.dll<br>
<br>
&gt;&gt;&gt; include Twitter::Model<br>
c:\tools\IronRuby\src\IronRuby.Libraries\Builtins\ModuleOps.cs:642:in
`ConstantMissing': uninitialized constant Object::<br>
Twitter (NameError)<o:p></o:p></p>

<div>

<p class=MsoNormal><br>
&nbsp; &nbsp; &nbsp; &nbsp;from :0:in `Initialize##1'<o:p></o:p></p>

</div>

<p class=MsoNormal>&gt;&gt;&gt; exit<o:p></o:p></p>

<div>

<p class=MsoNormal><br>
<br>
+ C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby<o:p></o:p></p>

</div>

<p class=MsoNormal>&raquo; ir -I
C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby\bin<br>
<br>
&gt;&gt;&gt; require 'Sylvester.Contracts, Version=<a href="http://1.0.0.0"
target="_blank">1.0.0.0</a>, Culture=neutral, PublicKeyToken=null'<br>
c:\tools\IronRuby\src\IronRuby.Libraries\Builtins\Kernel.cs:272:in `Require':
no such file to load -- Sylvester.Contract<br>
s, Version=<a href="http://1.0.0.0" target="_blank">1.0.0.0</a>,
Culture=neutral, PublicKeyToken=null (LoadError)<o:p></o:p></p>

<div>

<p class=MsoNormal><br>
&nbsp; &nbsp; &nbsp; &nbsp;from :0:in `Initialize##1'<o:p></o:p></p>

</div>

<p class=MsoNormal>&gt;&gt;&gt; exit<o:p></o:p></p>

<div>

<p class=MsoNormal style='margin-bottom:12.0pt'><br>
<br>
+ C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby<br>
&raquo; ir<o:p></o:p></p>

</div>

<p class=MsoNormal>&gt;&gt;&gt;
Dir.chdir('C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby\bin')<br>
=&gt; 0<br>
&gt;&gt;&gt; require 'Sylvester.Contracts, Version=<a href="http://1.0.0.0"
target="_blank">1.0.0.0</a>, Culture=neutral, PublicKeyToken=null'<br>
c:\tools\IronRuby\src\IronRuby.Libraries\Builtins\Kernel.cs:272:in `Require':
no such file to load -- Sylvester.Contract<br>
s, Version=<a href="http://1.0.0.0" target="_blank">1.0.0.0</a>,
Culture=neutral, PublicKeyToken=null (LoadError)<br>
&nbsp; &nbsp; &nbsp; &nbsp;from :0:in `Initialize##7'<br>
&gt;&gt;&gt; exit<o:p></o:p></p>

<div>

<p class=MsoNormal><br>
<br>
+ C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby<o:p></o:p></p>

</div>

<p class=MsoNormal>&raquo; ir -I
C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby\bin<br>
<br>
&gt;&gt;&gt; Dir.chdir('C:\projects\lumpr\src\Sylvester.DesktopEdition\Sylvester.IronRuby\bin')<br>
=&gt; 0<br>
&gt;&gt;&gt; require 'Sylvester.Contracts, Version=<a href="http://1.0.0.0"
target="_blank">1.0.0.0</a>, Culture=neutral, PublicKeyToken=null'<br>
c:\tools\IronRuby\src\IronRuby.Libraries\Builtins\Kernel.cs:272:in `Require':
no such file to load -- Sylvester.Contract<br>
s, Version=<a href="http://1.0.0.0" target="_blank">1.0.0.0</a>,
Culture=neutral, PublicKeyToken=null (LoadError)<br>
&nbsp; &nbsp; &nbsp; &nbsp;from :0:in `Initialize##8'<o:p></o:p></p>

<div>

<p class=MsoNormal style='margin-bottom:12.0pt'><br>
&gt;&gt;&gt;<br>
<br>
Thanks<br>
Ivan<br>
<br>
On 14/05/2008, at 10:42 AM, John Lam (IRONRUBY) wrote:<o:p></o:p></p>

</div>

<div>

<div>

<blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;
margin-top:5.0pt;margin-bottom:5.0pt'>

<p class=MsoNormal style='margin-bottom:12.0pt'>One more thing, r105 adds
support for the -I command line switch, so you can now:<br>
<br>
ir -I path-to-your-includes-directory yourapp.rb<br>
<br>
Thanks,<br>
-John<br>
<br>
<br>
-----Original Message-----<br>
From: <a href="mailto:ironruby-core-bounces@rubyforge.org" target="_blank">ironruby-core-bounces@rubyforge.org</a>
[mailto:<a href="mailto:ironruby-core-bounces@rubyforge.org" target="_blank">ironruby-core-bounces@rubyforge.org</a>]
On Behalf Of Ivan Porto Carrero<br>
Sent: Tuesday, May 13, 2008 3:32 PM<br>
To: <a href="mailto:ironruby-core@rubyforge.org" target="_blank">ironruby-core@rubyforge.org</a><br>
Subject: [Ironruby-core] r105 broke assembly loading<br>
<br>
Hi<br>
<br>
I just updated to r105 and now I can't require assemblies anymore.<o:p></o:p></p>

<blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;
margin-top:5.0pt;margin-bottom:5.0pt'>

<blockquote style='border:none;border-left:solid #CCCCCC 1.0pt;padding:0in 0in 0in 6.0pt;
margin-top:5.0pt;margin-bottom:5.0pt'>

<p class=MsoNormal>require 'bin/System.Net.dll'<o:p></o:p></p>

</blockquote>

</blockquote>

<p class=MsoNormal>c:\tools\IronRuby\src\IronRuby.Libraries\Builtins\Kernel.cs:272:in<br>
`Require': Invalid character '?' in expression (Synta<br>
xError)<br>
&nbsp; &nbsp; &nbsp; &nbsp;from :0:in `Initialize##1'<br>
<br>
Do I submit a bug for that?<br>
<br>
Cheers<br>
Ivan<br>
_______________________________________________<br>
Ironruby-core mailing list<br>
<a href="mailto:Ironruby-core@rubyforge.org" target="_blank">Ironruby-core@rubyforge.org</a><br>
<a href="http://rubyforge.org/mailman/listinfo/ironruby-core" target="_blank">http://rubyforge.org/mailman/listinfo/ironruby-core</a><br>
_______________________________________________<br>
Ironruby-core mailing list<br>
<a href="mailto:Ironruby-core@rubyforge.org" target="_blank">Ironruby-core@rubyforge.org</a><br>
<a href="http://rubyforge.org/mailman/listinfo/ironruby-core" target="_blank">http://rubyforge.org/mailman/listinfo/ironruby-core</a><o:p></o:p></p>

</blockquote>

<p class=MsoNormal><br>
_______________________________________________<br>
Ironruby-core mailing list<br>
<a href="mailto:Ironruby-core@rubyforge.org" target="_blank">Ironruby-core@rubyforge.org</a><br>
<a href="http://rubyforge.org/mailman/listinfo/ironruby-core" target="_blank">http://rubyforge.org/mailman/listinfo/ironruby-core</a><o:p></o:p></p>

</div>

</div>

</div>

<p class=MsoNormal><br>
_______________________________________________<br>
Ironruby-core mailing list<br>
<a href="mailto:Ironruby-core@rubyforge.org">Ironruby-core@rubyforge.org</a><br>
http://rubyforge.org/mailman/listinfo/ironruby-core<o:p></o:p></p>

</div>

<p class=MsoNormal><o:p>&nbsp;</o:p></p>

</div>

</body>

</html>