<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></head><body><div style="font-family:times new roman, new york, times, serif;font-size:12pt"><P>In one of my rake test I ran into the same problem. It looks like one of the method was getting a null value even though the method signature had&nbsp;&nbsp; [NotNull] with /*!*/.&nbsp;I added a code if the value is null return false and my rake test went through. It&nbsp;happened for all but one test so&nbsp;I am ok for now. It looks like it is not happening when you execute the same command in ir so I think it is specific to rake. I doubt, it has to do with ':each' in the teardown part of the rake test.</P>
<P>&nbsp;</P>
<P>Thanks.</P>
<DIV style="FONT-SIZE: 12pt; FONT-FAMILY: times new roman, new york, times, serif"><BR><BR>
<DIV style="FONT-SIZE: 12pt; FONT-FAMILY: times new roman, new york, times, serif">----- Original Message ----<BR>From: Andrew Peters &lt;andrew@mindscape.co.nz&gt;<BR>To: ironruby-core@rubyforge.org<BR>Sent: Tuesday, May 13, 2008 11:09:31 PM<BR>Subject: [Ironruby-core] rake test<BR><BR>Should I be able to run these?<BR><BR>I'm currently getting this error:<BR><BR>:0:in `do_generate': undefined local variable or method `methods' for main:Object (NoMethodError)<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from :0:in `#block162'<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from c:\Projects\IronRuby\trunk\src\IronRuby.Libraries\Extensions\IListOps.cs:785:in `Each'<BR>&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; from :0:in `Initialize##1'rake aborted!<BR>Command failed with status (1): ["c:\projects\ironruby\trunk\build\debug\ir...]<BR><BR>Cheers,<BR><BR>Andrew.<BR></DIV></DIV></div></body></html>