[Ironruby-core] [Bug Found: IronRuby 1.1.3 Gem install problem]

swap kotwal lists at ruby-forum.com
Thu Aug 8 11:08:30 UTC 2013


While installing $ gem install debugger -v '1.5.0'
I got struck on:-

WARNING:  RubyGems 1.2+ index not found for:


RubyGems will revert to legacy indexes degrading performance.
Updating metadata for 1 gems from http://rubygems.org/
.
complete
ERROR:  While executing gem ... (Errno::EACCES)
    Access to the path 'c:\Program Files\IronRuby 
1.1\Lib\ruby\gems\1.9.1\source
_cache' is denied.

My Gem env is:

$ gem env
RubyGems Environment:
  - RUBYGEMS VERSION: 1.3.7
  - RUBY VERSION: 1.9.2 (2010-08-18 patchlevel 0) [i386-mswin32]
  - INSTALLATION DIRECTORY: c:/Program Files/IronRuby 
1.1/Lib/ruby/gems/1.9.1
  - RUBY EXECUTABLE: "c:/Program Files/IronRuby 1.1/bin/ir.exe"
  - EXECUTABLE DIRECTORY: c:/Program Files/IronRuby 1.1/bin
  - RUBYGEMS PLATFORMS:
    - ruby
    - universal-dotnet-4.0
  - GEM PATHS:
     - c:/Program Files/IronRuby 1.1/Lib/ruby/gems/1.9.1
     - c:/Users/swapnil/.gem/ironruby/1.9.1
  - GEM CONFIGURATION:
     - :update_sources => true
     - :verbose => true
     - :benchmark => false
     - :backtrace => false
     - :bulk_threshold => 1000
  - REMOTE SOURCES:
     - http://rubygems.org/

-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list