[Ironruby-core] using external library (REXML) is extremely slow when running my app in debug mode

Mike Dalessio mike.dalessio at gmail.com
Wed Sep 5 19:26:15 UTC 2012


On Wed, Sep 5, 2012 at 3:12 PM, Anton Firsov <antonfir at gmail.com> wrote:

> I tried it now, but everything is the same.
> Have to use .NET xml api.
>

Has the ruby FFI library been ported to Ironruby? If so, It might be worth
trying Nokogiri 1.4.x, which uses FFI to talk to libxml2.

In fact, as the maintainer of Nokogiri and contributor to ruby-ffi, I'd be
interested to know if that works, and if not why not.


>
> Thanks for your answer,
> Anton
>
>
> 2012/9/2 Orion Edwards <Orion.Edwards at gallagher.co>
>
>> Without trying to reproduce the issue, perhaps it is related to the
>> debugger tracing information or exceptions from inside IronRuby caused by
>> REXML
>>
>> You could try enabling visual studio's "Just My Code" debugger option -
>> it's purpose is to filter out external stuff like this.
>>
>> It's on the Tools\Options dialog on the "Debugging" section
>>
>> *
>> ______________________________________________________**
>>
>> Orion Edwards **|** Technical Leader *
>> PHONE +64 7 838 9800 *|* FAX +64 7 838 9801 *|*
>> EMAIL orion.edwards at gallagher.co *|* WEB *www.gallagher.co*<http://www.gallagher.co/>
>>
>>
>>
>>
>> From:        Anton Firsov <antonfir at gmail.com>
>> To:        ironruby-core at rubyforge.org
>> Date:        01/09/2012 04:49 a.m.
>> Subject:        [Ironruby-core] using external library (REXML) is
>> extremely slow when running my app in debug mode
>> Sent by:        ironruby-core-bounces at rubyforge.org
>> ------------------------------
>>
>>
>>
>> Hi All,
>>
>> I'm using IronRuby as scripting environment inside my app. I use
>> scriptEngine.SetSearchPaths() to "include" the REXML files. The problem:
>> when I execute my app with F5 (debugger attached), my scripts run extremely
>> slow if I use REXML classes. If I use CTRL+F5 (no debugger), everything is
>> fine.
>>
>> Any tips how to workaround this issue?
>>
>> Is it possible, that a debugger is hooked inside my ScriptEngine, when it
>> executes .rb files? If yes, how can I eliminate it? I do not enable any
>> debugging options in my engine, and I unistalled the IronRuby VS2010
>> extension.
>>
>> Thanks,
>> Anton_______________________________________________
>> Ironruby-core mailing list
>> Ironruby-core at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/ironruby-core
>>
>>
>> _______________________________________________
>> Ironruby-core mailing list
>> Ironruby-core at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/ironruby-core
>>
>>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20120905/2f22f22c/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 3465 bytes
Desc: not available
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20120905/2f22f22c/attachment.gif>


More information about the Ironruby-core mailing list