[Ironruby-core] Problem with using OpenStruct and ERB

Orion Edwards Orion.Edwards at gallagher.co
Tue Jun 19 21:22:42 UTC 2012


I notice that in your example, you don't declare the local variable foo 
anywhere:
If I run it verbatim, both MRI and IronRuby fail with undefined method foo 
(and fair enough, foo isn't defined).
When I declare foo as a local variable, both MRI and IronRuby work fine 
for me.


______________________________________________________

Orion Edwards | Technical Leader 
PHONE +64 7 838 9800 | FAX +64 7 838 9801 | 
EMAIL orion.edwards at gallagher.co | WEB www.gallagher.co  




From:   Nathan Standiford <nstandif at live.com>
To:     <ironruby-core at rubyforge.org>
Date:   20/06/2012 04:55 a.m.
Subject:        [Ironruby-core] Problem with using OpenStruct and ERB
Sent by:        ironruby-core-bounces at rubyforge.org



I am using OpenStructs and ERB for template generation. In this simple 
example, ruby 1.8.6 runs this fine:
require "erb"
require "ostruct"
puts ERB.new("<%=foo%>", 0, "%<>").result(OpenStruct.new({ :foo => "bar" 
}).send(:binding))
 
However, it generates the following error when I run this in IronRuby 
1.1.3.0 on .NET 4.0.30319.269:
(erb):2: undefined method `foo' for main:Object (NoMethodError)
 
Does anyone know how to get this to behave correctly in IronRuby?
 _______________________________________________
Ironruby-core mailing list
Ironruby-core at rubyforge.org
http://rubyforge.org/mailman/listinfo/ironruby-core

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20120620/70d23bba/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/gif
Size: 3465 bytes
Desc: not available
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20120620/70d23bba/attachment-0001.gif>


More information about the Ironruby-core mailing list