[Ironruby-core] help: gem error

Shay Friedman shay.friedman at gmail.com
Thu Mar 10 09:31:52 EST 2011


What is the command you're trying to execute?

Shay.




On Tue, Mar 8, 2011 at 11:18 PM, Eric Vincent <eric at efvincent.com> wrote:

> Sorry for the noob level problem – but I’m trying to run igem.bat and I’m
> getting the following:
>
>
>
> C:/Program Files (x86)/IronRuby 1.1/Lib/ironruby/thread.rb:16:in
> `load_assembly': Specified type IronRuby.StandardLibrar
>
> y.Threading.ThreadingLibraryInitializer is not a subclass of
> IronRuby.Builtins.LibraryInitializer (LoadError)
>
>         from C:/Program Files (x86)/IronRuby 1.1/Lib/ironruby/thread.rb:16
>
>         from C:/Program Files (x86)/IronRuby
> 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:in `require'
>
>         from C:/Program Files (x86)/IronRuby
> 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:in `require'
>
>         from C:/Program Files (x86)/IronRuby
> 1.1/Lib/ruby/1.9.1/rubygems.rb:16
>
>         from C:/Program Files (x86)/IronRuby
> 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:in `require'
>
>         from C:/Program Files (x86)/IronRuby
> 1.1/Lib/ruby/1.9.1/rubygems/custom_require.rb:29:in `require'
>
>         from C:/Program Files (x86)/IronRuby 1.1/bin/gem:9
>
>
>
> I’ve got the 1.1.2 build, which I removed and reinstalled just in case. It
> works on my second computer. This machine is:
>
> Win7 Ultimate x64
>
> Lenovo W510
>
> 16 Gig
>
>
>
> I’ll gladly supply any other needed info
>
>
>
> Thanks in advance
>
> -e
>
>
>
> *IronRuby noob – but curious and ready to learn*
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20110310/0ed269c5/attachment.html>


More information about the Ironruby-core mailing list