[Ironruby-core] require_relative

Jimmy Schementi jschementi at gmail.com
Wed Jun 15 11:55:16 EDT 2011


On Jun 15, 2011, at 10:42 AM, Jacques du Preez wrote:
> Hi,
>  
> I’m getting the following error trying to use the require_relative method in Ruby:
>  
> “person.rb:3: undefined method `require_relative' for main:Object (NoMethodError)”
>  
> Is require_relative not supposed to be standard in Ruby 1.9? I know I can use require, but I thought require_relative is now standard in 1.9...

IronRuby's Ruby-1.9 support is not complete, and require_relative has not been implemented yet in IronRuby.

~js
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20110615/41384d88/attachment.html>


More information about the Ironruby-core mailing list