[Ironruby-core] [ANN] IronRuby 1.1.2 Released!

Jimmy Schementi jimmy at schementi.com
Tue Feb 8 15:23:15 EST 2011

Dear IronRuby community,

We’re pleased to announce the release of IronRuby 1.1.2. The binaries
and the installer are now available at CodePlex:

IronRuby 1.1.2 is a servicing release that keeps on improving
compatibility with Ruby 1.9.2 and includes IronRuby integration to
Visual Studio 2010. We decided to drop 1.8.6 compatibility mode in all
post-1.0 releases. We recommend using IronRuby 1.0 if you need 1.8.6

In this release we fixed several major issues:
- problems that blocked Gem installation in certain cases
- regex syntax: the parser was replaced with a new one that is much
more compatible with Ruby 1.9.2
- crashes or incorrect behavior on Windows Phone 7

The following bugs were fixed:
5728 Unable to create Ruby on Rails project using Visual Studio 2010,
error: can't convert NilClass into String
5638 IronRuby 1.1.1 + VS2010 Tools Installer does not include Windows bins
5650 installing rspec gem fails
5645 Installing rake ri documentation fails
5326 installing rspec gem fails
5667 Iron Rack Fixes
5695 Visual Studio 2010 Iron Ruby 1.1.1 Gem Problem is NOT FIXED!!!
4132 CLR strings are not the same as IronRuby strings as far as a Hash
is concerned
5572 Exception while compiling rbconfig
5441 Install to different location does not
5050 Implement String#encode (for JSON support)
4356 irw.exe
5144 Regex: Nested quantifier
4433 WP7 support
5117 Regexp not compat with MRI (failing REXML specs)

Thanks to everyone who contributed in any form! Keep it up!

-- IronRuby Team

More information about the Ironruby-core mailing list