[Ironruby-core] no such file to load -- spec/story (LoadError)

Sundae Oliseh lists at ruby-forum.com
Mon Nov 29 15:30:11 EST 2010


Thanks for your very detailled example Mike.
I've run into some issues while following it:

when I run the following statement: igem install cucumber -v=1.6.4
here's the error message I received:

C:\IronRuby\bin>igem install cucumber -v=1.6.4
ERROR:  could not find gem cucumber locally or in a repository

I searched around the net a little bit and found out that there is an 
alternative syntax:

C:\IronRuby\bin>igem install --source http://gems.rubyforge.org cucumber 
- v1.6.4

I ran it and got the follwing output

(::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) 
(::)

Thank you for installing cucumber-0.9.4.
Please be sure to read 
http://wiki.github.com/aslakhellesoy/cucumber/upgrading
for important information about this release. Happy cuking!

(::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) 
(::)

Successfully installed cucumber-0.9.4
ERROR:  could not find gem v1.6.4 locally or in a repository
1 gem installed
C:/Ruby192/lib/ruby/gems/1.9.1/gems/rdoc-2.5.11/lib/rdoc/ruby_lex.rb:67: 
warning
: parenthesize argument(s) for future version
Installing ri documentation for cucumber-0.9.4...
Installing RDoc documentation for cucumber-0.9.4...


As you can see, there is an error message in there. It did not 
ultimately install the correct version

-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list