[Ironruby-core] no such file to load -- spec/story (LoadError)

Sundae Oliseh lists at ruby-forum.com
Mon Nov 29 11:59:12 EST 2010


I am currently following this tutorial:

http://blog.webintellix.com/2009/10/how-to-use-cucumber-with-net-and-c.html

and I'm stuck on step 4 with the following error:

C:\Ruby192\bin>icucumber -help
c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib/gherkin/native
/ikvm.rb:16:in `load_assembly': Assembly 'gherkin' not found\nTry this: 
SET MONO
_PATH=c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib 
(or expo
rt MONO_PATH=...) (LoadError)
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib/g
herkin/native/ikvm.rb:16:in `native_impl'
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib/g
herkin/i18n.rb:7
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib/g
herkin/lexer/i18n_lexer.rb:1
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/gherkin-2.2.9-x86-mingw32/lib/g
herkin.rb:1
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/cucumber-0.9.4/bin/../lib/cucum
ber/cli/main.rb:5
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
 `require'
        from 
c:/Ruby192/lib/ruby/gems/1.9.1/gems/cucumber-0.9.4/bin/cucumber:5
        from C:/Ruby192/bin/cucumber:19:in `load'
        from C:/Ruby192/bin/cucumber:19





Sundae Oliseh wrote in post #964772:
> I'm running  IronRuby 1.0.0.0 on .NET 2.0.50727.3615 Mike.
>
> Mike Hatfield wrote in post #964264:
>> Hi Sundae,
>>
>> The articles in MSDN magazine are a little out dated.  What versions on
>> IronRuby are you running?  You can type in ir -v to get the version.  I
>> remember struggling with these articles when I first started out.  I'd
>> be
>> happy to give you a hand.
>>
>> Mike

-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list