[Ironruby-core] rspec no likely :(

Orion Edwards orion.edwards at gmail.com
Mon Nov 8 20:34:47 EST 2010


you always need to require 'rubygems' before requiring spec and friends,
even in MRI.

Are you doing that?

On Tue, Nov 9, 2010 at 1:31 PM, andrew Wilson <a.wilson82 at gmail.com> wrote:

> So I tried out the 1.1.1 release and am having a bit of issues.
>
> First the installer doesn't seem to care about the location I pick and
> installs to program files (x86) regardless.  I end up moving the files and
> redoing the paths but visual studio still expects the files to be in program
> files.
>
> Second, I can't get rspec to work for the life of me.  I am just doing--
>
> igem install rspec
>
> then in IR, I'm trying to test out mocking with:
>
> require 'spec' && require 'spec/mocks'
>
> both of which say they cannot be found.  If I require 'rubygems'
> 'spec/mocks' is found (but doesn't seem to work as I cannot stub anything)
> but 'spec' is not.
>
> Any thoughts on what I can do to salvage this?
>
> -Andrew
>
> --
> “If I had six hours to chop down a tree, I’d spend the first four of them
> sharpening my axe”.
>
> -Abraham Lincoln
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20101109/fa398570/attachment.html>


More information about the Ironruby-core mailing list