[Ironruby-core] iron-term-ansicolor 0.0.2 Released

Will Green will at hotgazpacho.org
Mon Mar 1 13:55:25 EST 2010


As a temporary workaround, I've uploaded the gem to the downloads section
for the project:

http://github.com/hotgazpacho/iron-term-ansicolor/downloads

Simply download, then, in the directory you downloaded to:

ir -S gem install iron-term-ansicolor-0.0.2.gem
<http://github.com/hotgazpacho/iron-term-ansicolor/downloads>
--
Will Green
http://hotgazpacho.org/


On Mon, Mar 1, 2010 at 1:41 PM, Ivan Porto Carrero <
ivan at whiterabbitconsulting.eu> wrote:

> I also get it when I try to install from a remote location. But downloading
> the source and building the gem does work.
> ---
> Met vriendelijke groeten - Best regards - Salutations
> Ivan Porto Carrero
> Web: http://whiterabbitconsulting.eu - http://flanders.co.nz
> Twitter: http://twitter.com/casualjim
> Author of IronRuby in Action (http://manning.com/carrero)
> Microsoft IronRuby/C# MVP
>
>
>
> On Mon, Mar 1, 2010 at 7:39 PM, Jim Deville <jdeville at microsoft.com>wrote:
>
>> C:\Users\jdeville\projects\cucumber
>>
>> [35] » ir -S gem sources
>>
>> *** CURRENT SOURCES ***
>>
>>
>>
>> http://gemcutter.org
>>
>> http://gems.rubyforge.org/
>>
>> http://gems.github.com
>>
>>
>>
>> That’s what I have for sources, fyi. I’ll try to look into it more later
>> if no one else does.
>>
>>
>>
>> JD
>>
>>
>>
>> *From:* ironruby-core-bounces at rubyforge.org [mailto:
>> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Will Green
>> *Sent:* Monday, March 01, 2010 10:34 AM
>>
>> *To:* ironruby-core at rubyforge.org
>> *Subject:* Re: [Ironruby-core] iron-term-ansicolor 0.0.2 Released
>>
>>
>>
>> I am seeing this error, too :-(
>>
>>
>>
>> I can install locally. Perhaps it is a problem with the Gem sources?
>>
>>
>>
>> C:\Users\will.green\dev\iron-term-ansicolor\pkg>ir -S gem install
>> iron-term-ansicolor-0.0.2.gem
>>
>> Successfully installed iron-term-ansicolor-0.0.2
>>
>> 1 gem installed
>>
>> Installing ri documentation for iron-term-ansicolor-0.0.2...
>>
>>
>>
>> unrecognized option `--format'
>>
>>
>>
>> For help on options, try 'rdoc --help'
>>
>>
>> --
>> Will Green
>> http://hotgazpacho.org/
>>
>> On Mon, Mar 1, 2010 at 1:04 PM, Jim Deville <jdeville at microsoft.com>
>> wrote:
>>
>> Having issues installing this with ironruby rc2. Anyone else seeing that?
>> I tried running:
>>
>>
>>
>> ir -S gem install cucumber iron-term-ansicolor
>>
>>
>>
>> Pasted output:
>>
>> [20] » ir -v -e 'exit'
>>
>> IronRuby 0.9.4.0 on .NET 2.0.50727.4927
>>
>> C:\temp
>>
>> [21] » ir -S gem install cucumber iron-term-ansicolor
>>
>>
>>
>> (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::)
>>
>>
>>
>>                      (::)   U P G R A D I N G    (::)
>>
>>
>>
>> Thank you for installing cucumber-0.6.2.
>>
>> Please be sure to read
>> http://wiki.github.com/aslakhellesoy/cucumber/upgrading
>>
>> for important information about this release. Happy cuking!
>>
>>
>>
>> (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::) (::)
>>
>>
>>
>> Successfully installed term-ansicolor-1.0.4
>>
>> Successfully installed polyglot-0.3.0
>>
>> Successfully installed treetop-1.4.4
>>
>> Successfully installed builder-2.1.2
>>
>> Successfully installed diff-lcs-1.1.2
>>
>> Successfully installed json_pure-1.2.2
>>
>> Successfully installed cucumber-0.6.2
>>
>> ERROR:  While executing gem ... (IndexError)
>>
>>     Index was outside the bounds of the array.
>>
>> C:\temp
>>
>> [22] » ir -S gem install iron-term-ansicolor
>>
>> ERROR:  While executing gem ... (IndexError)
>>
>>     Index was outside the bounds of the array.
>>
>> C:\temp
>>
>> [23] »
>>
>>
>>
>> JD
>>
>>
>>
>>
>>
>> *From:* ironruby-core-bounces at rubyforge.org [mailto:
>> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Shri Borde
>> *Sent:* Sunday, February 28, 2010 10:20 PM
>> *To:* ironruby-core at rubyforge.org
>> *Subject:* Re: [Ironruby-core] iron-term-ansicolor 0.0.2 Released
>>
>>
>>
>> Very cool!
>>
>>
>>
>> So if a user runs Cucumber on IronRuby, does Cucumber give the right error
>> message about having to install iron-term-ansicolor? Cucumber used to say
>> that you had to install win32console. Just checking that iron-term-ansicolor
>> will be easily discoverable.
>>
>>
>>
>> *From:* ironruby-core-bounces at rubyforge.org [mailto:
>> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Will Green
>> *Sent:* Friday, February 26, 2010 8:15 PM
>> *To:* ironruby-core
>> *Subject:* [Ironruby-core] iron-term-ansicolor 0.0.2 Released
>>
>>
>>
>> Tonight, I released an update to iron-term-ansicolor, a library for
>> IronRuby that provides console colors for apps like RSpec and Cucumber
>> (Cucumber already makes use of this, and I bet it would not be too much
>> trouble to add to RSpec).
>>
>>
>>
>> http://rubygems.org/gems/iron-term-ansicolor
>>
>>
>>
>> igem install iron-term-ansicolor
>>
>>
>>
>> The source is available on github:
>> http://github.com/hotgazpacho/iron-term-ansicolor
>>
>>
>>
>> Big thanks to Danny Coates for devising a much better way to parse the
>> ANSI control codes!
>>
>>
>> --
>> Will Green
>> http://hotgazpacho.org/
>>
>>
>> _______________________________________________
>> Ironruby-core mailing list
>> Ironruby-core at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/ironruby-core
>>
>>
>>
>> _______________________________________________
>> Ironruby-core mailing list
>> Ironruby-core at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/ironruby-core
>>
>>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100301/f829dbda/attachment.html>


More information about the Ironruby-core mailing list