[Ironruby-core] bug?

Jimmy Schementi Jimmy.Schementi at microsoft.com
Tue Jun 29 14:51:42 EDT 2010

True, but I’m not seeing this reproduce (granted I’m trying on a 64-bit machine, but that shouldn’t make a difference). Can you list what envvars you have set?

C:\Program Files (x86)\IronRuby 1.0v4\bin>igem install faster_rubygems
Building native extensions.  This could take a while...

faster_rubygems installed! see the readme for post-install instructions: http://github.com/rdp/faster_rubygems

recreating all faster_rubygems caches
faster_rubygems: creating caches
Successfully installed faster_rubygems-0.9.2
1 gem installed
Installing ri documentation for faster_rubygems-0.9.2...
Installing RDoc documentation for faster_rubygems-0.9.2...

C:\Program Files (x86)\IronRuby 1.0v4\bin>

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Will Green
Sent: Tuesday, June 29, 2010 11:42 AM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] bug?

"C:/Program Files/IronRuby 1.0v4/bin/ir.exe" -rubygems C:/Program
Files/IronRuby 1.0v4/lib/ironruby/gems/1.8/gems/rake-0.8.7/bin/rake
RUBYARCHDIR="C:/Program Files/IronRuby
RUBYLIBDIR="C:/Program Files/IronRuby
unknown: Could not find file 'C:\Program'. (Errno::ENOENT)

Seems pretty clear to me that it is a path interpolation problem. "Could not find file 'C:\Program'". Doesn't seem to like the space in the directory name.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100629/ca61648f/attachment-0001.html>

More information about the Ironruby-core mailing list