[Ironruby-core] bug?

Roger Pack lists at ruby-forum.com
Tue Jun 29 14:01:28 EDT 2010


> D:\> ir -e "require 'rubygems'; puts Gem::VERSION"
> 1.3.5

Ok, tried it with "default" rubygems...

Seems to still have said problem...


C:\dev\ruby\faster_rubygems>ir -e "require 'rubygems'; puts 
Gem::VERSION"
1.3.5

C:\dev\ruby\faster_rubygems>ir -S gem install faster_rubygems-0.9.3.gem
Building native extensions.  This could take a while...
ERROR:  Error installing faster_rubygems-0.9.3.gem:
        ERROR: Failed to build gem native extension.

"C:/Program Files/IronRuby 1.0v4/bin/ir.exe" mkrf_conf.rb
Installed--thank you for trying out faster_rubygems
recreating all faster_rubygems caches
faster_rubygems: creating all caches
..
"C:/Program Files/IronRuby 1.0v4/bin/ir.exe" -rubygems C:/Program 
Files/IronRuby 1.0v4/lib/ironruby/gems/1.8/gems/rake-0.8.7/bin/rake 
RUBYARCHDIR="C:/Program Files/IronRuby 
1.0v4/lib/ironruby/gems/1.8/gems/faster_rubygems-0.9.3/lib" 
RUBYLIBDIR="C:/Program Files/IronRuby 
1.0v4/lib/ironruby/gems/1.8/gems/faster_rubygems-0.9.3/lib"
unknown: Could not find file 'C:\Program'. (Errno::ENOENT)



Gem files will remain installed in C:/Program Files/IronRuby 
1.0v4/lib/ironruby/gems/1.8/gems/faster_rubygems-0.9.3 for inspection.
Results logged to C:/Program Files/IronRuby 
1.0v4/lib/ironruby/gems/1.8/gems/faster_rubygems-0.9.3/ext/gem_make.out
-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list