[Ironruby-core] WatiN .NET 4.0 and the loadFromRemoteSources Element in App.config

Mohammad Azam azamsharp at gmail.com
Mon Jun 21 11:39:12 EDT 2010


I am using .NET 4.0 with IronRuby to invoke some methods on WatiN framework
2.0.10.928.

I keep getting the following error when loading the WatiN assemblies:


C:\Projects\IronRubyDemo\IronRubyDemoSolution\BusinessObjects>ir -S spec
testacc
ountbalanceUI.rb
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:30:in
`require': A
n attempt was made to load an assembly from a network location which would
have
caused the assembly to be sandboxed in previous versions of the .NET
Framework.
This release of the .NET Framework does not enable CAS policy by default, so
thi
s load may be dangerous. If this load is not intended to sandbox the
assembly, p
lease enable the loadFromRemoteSources switch. See
http://go.microsoft.com/fwlin
k/?LinkId=155569 for more information. (LoadError)
        from
C:/IronRuby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:30:in
 `require'


So, I went to the App.config file of my project and added the following
lines:

<?xml version="1.0" encoding="utf-8" ?>
<configuration>

  <runtime>
    <loadFromRemoteSources enabled="true" />
  </runtime>

</configuration>

I tried running it again and encountered the same problem. Any ideas!
-- 
Mohammad Azam
MVP (Microsoft Valuable Professional)
www.highoncoding.com
www.azamsharp.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100621/dba03b40/attachment.html>


More information about the Ironruby-core mailing list