[Ironruby-core] MRI 1.8.7 compatibility

Jimmy Schementi Jimmy.Schementi at microsoft.com
Sun Feb 14 16:17:23 EST 2010


Here's the current compatibility plan, let me know if this concerns anyone:


> IronRuby 1.0.x releases: ONLY ruby-1.8.6 compatible
> ===================================================
> IronRuby has created a 1.0-servicing branch (not on GitHub yet, 
> but shortly); all ruby-1.8.6 compatible releases will come out 
> of that branch, starting with the just-released 1.0-rc2, followed
> by 1.0, and any future 1.0.x releases. We will also removing any 
> 1.9 features from the 1.0-servicing branch (-19 and -20 flags), 
> so IronRuby 1.0 will only be 1.8.6 compatible.
>
>
> IronRuby 1.x releases: ONLY ruby-1.9 compatible
> ===============================================
> Active development will still happens in the master branch, which 
> will be only focused on ruby-1.9 support. This means the master
> branch will lose ruby-1.8.6 compatibility as breaking changes 
> between ruby-1.8.6 and ruby-1.9 are implemented. However, we'll 
> probably look at implementing 1.8.7 features that are also in 1.9, 
> so we might get ruby-1.8.7 compatibility as a byproduct of that,
> but it's not something we'll be testing.


Most ruby implementations are also moving away from supporting 1.8
and 1.9 in the same codebase as well. Even more extreme, MacRuby is 
completely skipping 1.8 compatibility, but that technically makes sense
as they are a fork of the 1.9 codebase.

~Jimmy


More information about the Ironruby-core mailing list