[Ironruby-core] Error with Rails and DBI::Date

Jimmy Schementi jimmy at schementi.com
Sun Aug 8 16:25:55 EDT 2010


activerecord-sqlserver-adapter now supports IronRuby directly, and does not
depend on any of the DBI gems (I update
http://ironruby.net/documentation/rails a while ago with this). Try just
installing activerecord-sqlserver-adapter-2.3.8 without any of those DBI
gems, as they might be doing something incompatible with DBI::Date.

~Jimmy


On Tue, Aug 3, 2010 at 4:06 AM, Shay Friedman <shay.friedman at gmail.com>wrote:

> I've reinstalled IR since then so I don't have the list now. I remember it
> was something with the deprecated gem... try to install a previous version
> of it.
>
> Not sure though. I'll have time to look into it only in a few days.
> Has someone here run into this problem, fixed it and have the solution at
> hand?
>
> Shay.
>
>
> On Tue, Aug 3, 2010 at 5:52 AM, Jack Hong <lists at ruby-forum.com> wrote:
>
>> Hi Shay,
>>
>> I am facing the same problem. Could you find out which versions of these
>> gems you need to reinstall? Here is my list:
>>
>> Successfully installed deprecated-3.0.0
>> Successfully installed dbi-0.4.3
>> Successfully installed dbd-adonet-0.3.2
>> Successfully installed dbd-adonet-sqlserver-0.3.2
>> Successfully installed activerecord-sqlserver-adapter-2.3.1
>> Successfully installed activerecord-adonet-sqlserver-0.3.4
>>
>> I am running rails 2.3.8, btw.
>>
>> Cheers,
>> Jack
>> Shay Friedman wrote:
>> > It turned out to be some kind of a gem versions mess... Had to uninstall
>> > several gems and reinstall them to get it going.
>> >
>> > Shay.
>> >
>> > Shay Friedman wrote:
>> >> Hi guys,
>> >>
>> >> I'm on a new computer and I'm trying to run rails (via IronRuby) for
>> the
>> >> first time here.
>> >> I have installed the rake, rails and activerecord-adonet-sqlserver
>> gems,
>> >> added the config.gem line to environment.rb and updated the
>> database.yml
>> >> file.
>> >>
>> >> As soon as I try to run the WEBrick I get the next exception:
>> >> 'alias_method': undefined method `public' for class `DBI::Date'
>> >> (NameError)
>> >>
>> >> This is caused because of line 57 in the date.rb file of the DBI gem:
>> >> deprecate :initialize, :public
>> >>
>> >> I replaced the DBI gem with Ivan's Ironruby-dbi gem but it didn't help.
>> >>
>> >> Has anyone run into this problem?
>> >>
>> >> Thanks,
>> >> Shay.
>>
>> --
>> Posted via http://www.ruby-forum.com/.
>> _______________________________________________
>> Ironruby-core mailing list
>> Ironruby-core at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/ironruby-core
>>
>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100808/e2ae10dd/attachment.html>


More information about the Ironruby-core mailing list