[Ironruby-core] Running Webrick with RAILS_ENV=production

Chris Ortman chrisortman at gmail.com
Fri Apr 30 18:14:02 EDT 2010


It is the config.gem 'activerecord-adonet-sqlserver' line that causes the
error....

I have gotten past it by adding
require 'activerecord_adonet_sqlserver'
after require File.join(File.dirname(__FILE__),'boot') in
config/environment.rb

However after doing that I'm still not able to get rake test to work.... it
fails because it can't load driver 'ADO'

On Thu, Apr 22, 2010 at 10:37 PM, Shane Holder <SHolder at randgrp.com> wrote:

>  Apologies if this makes it to the list twice, I seem to be having issues
> with mailman.
>
>
>
> I know this probably isn't an ideal situation, but I'm building a small app
> for myself (1st rails app) and I want to be able to switch between
> dev/test/production.  So, I set RAILS_ENV=production and tried to run the
> server as below but I get the following error.  It's probably something on
> my end but I'm not sure where to look, can someone shed some light?
>
>
>
> Thanks,
>
> Shane Holder
>
>
>
> SHolder at SHOLDER7 TaskStatus [master +0 ~5 -1 !]> ir -S .\script\server
>
> => Booting WEBrick
>
> => Rails 2.3.5 application starting on http://0.0.0.0:3000
>
> ir.exe : C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require':
> can't convert nil into String (TypeError)
>
> At line:1 char:3
>
> + ir <<<<  -S .\script\server
>
>     + CategoryInfo          : NotSpecified: (C:/Program File...ing
> (TypeError):String) [], RemoteException
>
>     + FullyQualifiedErrorId : NativeCommandError
>
>
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require
>
> '
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
> `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:490:in
> `new_constants_in'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:154:in
> `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:269:in
> `require_frameworks'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:269:in
> `each'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:269:in
> `require_frameworks'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:135:in
> `process'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:114:in
> `__send__'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/initializer.rb:114:in `run'
>
>     from C:/d/TaskStatus/config/environment.rb:9
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:29:in `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:156:in
> `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:490:in
> `new_constants_in'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/activesupport-2.3.5/lib/active_support/dependencies.rb:154:in
> `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ironruby/gems/1.8/gems/rails-2.3.5/lib/commands/server.rb:84
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:30:in `require'
>
>     from C:/Program Files (x86)/IronRuby
> 1.0v4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:30:in `require'
>
>     from ./script/server:3
>
>
>
> Shane Holder
>
> The Rand Group, LLC
>
> sholder at randgrp.com <dstejskal at randgrp.com>
>
> 972.978.6559 Cell
>
> 713.341.9387 Direct
>
> 713.850.0747 Main Office
>
> www.randgrp.com
>
> [image: trg_email_logo (2)]
>
>
>
> ------------------------------
> This email message and any attachments are intended for use by the
> addressee(s) named herein and may contain legally privileged and/or
> confidential information. If you are not the intended recipient of this
> email you are hereby notified that any dissemination, distribution or
> copying of this email and any attachments thereto is strictly prohibited. If
> you have received this email in error please notify the sender and
> permanently delete the original and any copies of this email and any prints
> thereof.
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100430/2b725bcf/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: image/jpeg
Size: 3611 bytes
Desc: not available
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100430/2b725bcf/attachment.jpe>


More information about the Ironruby-core mailing list