[Ironruby-core] RubyGems 1.3.6, Bundler, etc.

Jim Deville jdeville at microsoft.com
Mon Apr 26 13:41:15 EDT 2010

This is the comment we got from Eric (RubyGems maintainer).


>Comment By: Eric Hodel (drbrain)
Date: 2010-04-20 20:47

rubygems/defaults/ironruby.rb would go in RbConfig::CONFIG['rubylibdir'] (not in RuybGems) so it should be picked up even by setup.rb

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Ryan Riley
Sent: Saturday, April 24, 2010 11:33 AM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

Where exactly does the #{RUBY_ENGINE}.rb file go? I am having a hard time finding the location. I changed the impl. of default_exec_format and was able to update RubyGems. However, I think adding the ruby engine file is a better way to go.

Ryan Riley

On Thu, Apr 22, 2010 at 11:39 PM, Tomas Matousek <Tomas.Matousek at microsoft.com<mailto:Tomas.Matousek at microsoft.com>> wrote:

This is a bug in RubyGems. It seems that we can get around it by providing lib/rubygems/ironruby.rb file:



From: ironruby-core-bounces at rubyforge.org<mailto:ironruby-core-bounces at rubyforge.org> [mailto:ironruby-core-bounces at rubyforge.org<mailto:ironruby-core-bounces at rubyforge.org>] On Behalf Of Ryan Riley
Sent: Thursday, April 22, 2010 10:07 PM

To: ironruby-core at rubyforge.org<mailto:ironruby-core at rubyforge.org>
Subject: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

While trying to install DataMapper from source, I ran into a few additional issues. I can create cases if they are legit, but I suspect I'm just missing something. When I tried to install dm-more, I received an error stating I didn't have bundler installed. When I tried installing bundler, I couldn't because it requires RubyGems 1.3.6. When I tried executing `ir -S gem update --system`, I received the following:

C:\Users\ryan>ir -S gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR:  While executing gem ... (Gem::Exception)
    [BUG] invalid exec_format "ir", no %s

Is IronRuby telling me it has a known bug, or is this something else? Can I upgrade to RubyGems 1.3.6? Can I install Bundler?


Ryan Riley

Email: ryan.riley at panesofglass.org<mailto:ryan.riley at panesofglass.org>
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/

Ironruby-core mailing list
Ironruby-core at rubyforge.org<mailto:Ironruby-core at rubyforge.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100426/053a4354/attachment-0001.html>

More information about the Ironruby-core mailing list