[Ironruby-core] Installing Bundler on IronRuby

Ryan Riley ryan.riley at panesofglass.org
Sat Apr 24 14:49:18 EDT 2010


When trying to install Bundler from source with IronRuby (since the RubyGems
update seems to have lost the ability to do this), I received the following.
I'll try looking into this, but I wanted to post it just in case someone
else sees anything obvious:

c:\Users\ryan\dev\bundler>ir -S rake install --trace
(in c:/Users/ryan/dev/bundler)
** Invoke install (first_time)
** Invoke package (first_time)
** Invoke gem (first_time)
** Invoke pkg/bundler-0.9.25.pre.gem (first_time, not_needed)
** Invoke pkg (first_time, not_needed)
** Invoke bin/bundle (first_time, not_needed)
** Invoke lib/bundler (first_time, not_needed)
** Invoke lib/bundler.rb (first_time, not_needed)
** Invoke lib/bundler/templates (first_time, not_needed)
** Invoke lib/bundler/vendor (first_time, not_needed)
** Invoke lib/bundler/cli.rb (first_time, not_needed)
** Invoke lib/bundler/definition.rb (first_time, not_needed)
** Invoke lib/bundler/dependency.rb (first_time, not_needed)
** Invoke lib/bundler/dsl.rb (first_time, not_needed)
** Invoke lib/bundler/environment.rb (first_time, not_needed)
** Invoke lib/bundler/index.rb (first_time, not_needed)
** Invoke lib/bundler/installer.rb (first_time, not_needed)
** Invoke lib/bundler/remote_specification.rb (first_time, not_needed)
** Invoke lib/bundler/resolver.rb (first_time, not_needed)
** Invoke lib/bundler/rubygems_ext.rb (first_time, not_needed)
** Invoke lib/bundler/runtime.rb (first_time, not_needed)
** Invoke lib/bundler/settings.rb (first_time, not_needed)
** Invoke lib/bundler/setup.rb (first_time, not_needed)
** Invoke lib/bundler/shared_helpers.rb (first_time, not_needed)
** Invoke lib/bundler/source.rb (first_time, not_needed)
** Invoke lib/bundler/spec_set.rb (first_time, not_needed)
** Invoke lib/bundler/ui.rb (first_time, not_needed)
** Invoke lib/bundler/version.rb (first_time, not_needed)
** Invoke lib/bundler/templates/environment.erb (first_time, not_needed)
** Invoke lib/bundler/templates/Gemfile (first_time, not_needed)
** Invoke lib/bundler/vendor/thor (first_time, not_needed)
** Invoke lib/bundler/vendor/thor.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/core_ext (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/parser (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/shell (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/base.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/error.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/invocation.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/parser.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/shell.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/task.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/util.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/version.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/core_ext/file_binary_read.rb (first_time,
not_needed)
** Invoke lib/bundler/vendor/thor/core_ext/hash_with_indifferent_access.rb
(first_time, not_needed)
** Invoke lib/bundler/vendor/thor/core_ext/ordered_hash.rb (first_time,
not_needed)
** Invoke lib/bundler/vendor/thor/parser/argument.rb (first_time,
not_needed)
** Invoke lib/bundler/vendor/thor/parser/arguments.rb (first_time,
not_needed)
** Invoke lib/bundler/vendor/thor/parser/option.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/parser/options.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/shell/basic.rb (first_time, not_needed)
** Invoke lib/bundler/vendor/thor/shell/color.rb (first_time, not_needed)
** Invoke LICENSE (first_time, not_needed)
** Invoke README.md (first_time, not_needed)
** Invoke ROADMAP.md (first_time, not_needed)
** Invoke CHANGELOG.md (first_time, not_needed)
** Invoke gemspec (first_time)
** Execute gemspec
** Execute gem
** Invoke gemspec
** Execute package
** Execute install
gem install pkg/bundler-0.9.25.pre
ERROR:  While executing gem ... (ArgumentError)
    while scanning a block mapping: expected <block end>, but found:
#<ScalarToken Value="across many machines, systematically and repeatably"
Style="None"> (line 38, column 1)
rake aborted!
Command failed with status (1): [gem install pkg/bundler-0.9.25.pre...]
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:995:in `sh'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:1010:in `call'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:1010:in `sh'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:1091:in `sh'
c:/Users/ryan/dev/bundler/rakefile:94
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `call'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:636:in `execute'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `each'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:631:in `execute'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:597:in
`invoke_with_call_chain'
C:/Program Files (x86)/IronRuby 1.0/lib/ruby/1.8/monitor.rb:242:in
`mon_synchronize'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:590:in
`invoke_with_call_chain'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:583:in `invoke'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2051:in
`invoke_task'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in `each'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2029:in
`top_level'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exception_handling'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2023:in
`top_level'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2001:in `run'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:2068:in
`standard_exception_handling'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/lib/rake.rb:1998:in `run'
C:/Users/ryan/.gem/ironruby/1.8/gems/rake-0.8.7/bin/rake:31
C:/Users/ryan/.gem/ironruby/1.8/bin/rake:19:in `load'
C:/Users/ryan/.gem/ironruby/1.8/bin/rake:19

Ryan Riley

Email: ryan.riley at panesofglass.org
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100424/44cf1f30/attachment.html>


More information about the Ironruby-core mailing list