[Ironruby-core] RubyGems 1.3.6, Bundler, etc.

Tomas Matousek Tomas.Matousek at microsoft.com
Fri Apr 23 02:39:43 EDT 2010

This is a bug in RubyGems. It seems that we can get around it by providing lib/rubygems/ironruby.rb file:



From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Ryan Riley
Sent: Thursday, April 22, 2010 10:07 PM
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] RubyGems 1.3.6, Bundler, etc.

While trying to install DataMapper from source, I ran into a few additional issues. I can create cases if they are legit, but I suspect I'm just missing something. When I tried to install dm-more, I received an error stating I didn't have bundler installed. When I tried installing bundler, I couldn't because it requires RubyGems 1.3.6. When I tried executing `ir -S gem update --system`, I received the following:

C:\Users\ryan>ir -S gem update --system
Updating RubyGems
Updating rubygems-update
Successfully installed rubygems-update-1.3.6
Updating RubyGems to 1.3.6
Installing RubyGems 1.3.6
ERROR:  While executing gem ... (Gem::Exception)
    [BUG] invalid exec_format "ir", no %s

Is IronRuby telling me it has a known bug, or is this something else? Can I upgrade to RubyGems 1.3.6? Can I install Bundler?


Ryan Riley

Email: ryan.riley at panesofglass.org<mailto:ryan.riley at panesofglass.org>
LinkedIn: http://www.linkedin.com/in/ryanriley
Blog: http://wizardsofsmart.net/
Twitter: @panesofglass
Website: http://panesofglass.org/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20100423/ae563031/attachment.html>

More information about the Ironruby-core mailing list