[Ironruby-core] win32api breaks gems on mono

Ivan Porto Carrero ivan at flanders.co.nz
Sat Oct 3 11:28:43 EDT 2009

The new win32api additions don't work on another OS than windows.
This breaks rubygems and most likely rightly so.

+ivan at ivan-mbp:~/Downloads/ironruby-2be42fd
» igem list
IronRuby.Libraries:0:in `GetFunction': LoadLibrary
from :0:in `initialize'
 from IronRuby.Libraries:0:in `Create'
 from etc.rb:0
from :0:in `require'
from /usr/local/cloudslide/ironruby/bin/igem:8
 from :0:in `require'

renaming the win32api.rb file in lib/IronRuby changes the error about
kernel32 not being on the system.

Met vriendelijke groeten - Best regards - Salutations
Ivan Porto Carrero
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim
Author of IronRuby in Action (http://manning.com/carrero)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20091003/29bc22d3/attachment.html>

More information about the Ironruby-core mailing list