[Ironruby-core] Using IronPython code from IronRuby

Shay Friedman shay.friedman at gmail.com
Sun Nov 22 08:04:02 EST 2009


Hi,

I'm trying to load an IronPython file in IronRuby (via IronRuby.require) and
I get an exception: "Failed to load language 'IronPython 2.6': type
'IronPython.Runtime.PythonContext' is not a valid language provider because
it does not inherit from LanguageContext".

This is thrown from the require method.

What am I doing wrong?

Thanks,
Shay.

-- 
--------------------------------------------------
Shay Friedman
Author of IronRuby Unleashed
http://www.IronShay.com
Follow me: http://twitter.com/ironshay
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20091122/0a6a9981/attachment.html>


More information about the Ironruby-core mailing list