[Ironruby-core] Confused - trying to run the specs

Jim Deville jdeville at microsoft.com
Wed Mar 25 11:30:04 EDT 2009


I have this fixed in my Git fork. I'll be pulling it in this week. In the mean time, change Merlin/External/Languages/IronRuby/mspec/default.mspec to set :target, "/path/to/Merlin/Main/bin/debug/ir.exe".

Sorry for the trouble.

JD

-----Original Message-----
From: Thibaut Barrère <thibaut.barrere at gmail.com>
Sent: March 25, 2009 3:50 AM
To: ironruby-core at rubyforge.org <ironruby-core at rubyforge.org>
Subject: Re: [Ironruby-core] Confused - trying to run the specs



Hi,

I tried that:

set HOME=%USERPROFILE%
then dev.bat

then:

U:\Merlin\External\Languages\IronRuby\mspec>mspec :core
U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `exec': No such file or directory - U:\Merlin\Main\Test\Scripts\ir.cmd (Errno::ENOENT)
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `run'
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/utils/script.rb:203:in `main'
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/bin/mspec:7

U:\Merlin\External\Languages\IronRuby\mspec>echo %HOME%
C:\Documents and Settings\Thibaut Barrère

At this point there is a .mspecrc in HOME, and MERLIN_ROOT is set to U:\Merlin\Main

Calling dev.bat first then setting HOME does not change the behaviour.

I also removed all known references to some IR version from my PATHs (both user and system), pulled the last ironruby bits, compiled again and retried, but it raises the same error.

Maybe it's a cause: in which folder should I be before I call mspec ci ?

No idea what's going on for the moment, any hint will be most welcome.

-- Thibaut

2009/3/25 Shri Borde <Shri.Borde at microsoft.com<mailto:Shri.Borde at microsoft.com>>

This does seem to be an issue with HOME not being set which Adam Khatava was also running into. Can you try setting HOME before running dev.bat? Dev.bat copies default.mspec to the HOME folder allowing the “mspec ci” command to know where to find the tests. So setting HOME after running dev.bat will *not* work.



I have a change for dev.bat to set HOME if it is not set already. If you could confirm that setting HOME before running dev.bat works, then I will know that my change is actually the right fix for your problem.



Tags are a way to disable tests. Browsing the ironruby-tags folder will tell you what does not work. See http://rubyspec.org/wiki/mspec/Mspec-tag for some info.



Thanks,

Shri



From: ironruby-core-bounces at rubyforge.org<mailto:ironruby-core-bounces at rubyforge.org> [mailto:ironruby-core-bounces at rubyforge.org<mailto:ironruby-core-bounces at rubyforge.org>] On Behalf Of Thibaut Barrère

Sent: Tuesday, March 24, 2009 2:54 PM
To: ironruby-core
Subject: [Ironruby-core] Confused - trying to run the specs



Hi,



I'm having a closer look at the source in order to attempt some work around system and IO popen.



I pulled the code, ran dev.bat etc. The build runs fine.



Now I'm trying to run the specs and something must be not quite right - or I'm not invoking the right modjo. Maybe some confusion with some existing install on the system, I'm not sure.



I've tried (U: is my github root):



U:\>mspec ci core\kernel\system

ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]



Finished in 0.000000 seconds



0 files, 0 examples, 0 expectations, 0 failures, 0 errors

also tried:



U:\Merlin\External\Languages\IronRuby\mspec>mspec :core

U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `exec': No such file or directory - U:\Merlin\Main\Test\Scripts\ir.cmd (Errno::ENOENT)

        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `run'

        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/utils/script.rb:203:in `main'

        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/bin/mspec:7



I have no HOME var set. I tried setting it but it doesn't seem to change anything currently.



So any hint will help me go further here (I'll continue diving in here). Are there some steps I should carry out ?



As well, is there an explanation of what "tags" are for ? Are these some way to track the specs that aren't passing ?



cheers,



-- Thibaut



_______________________________________________
Ironruby-core mailing list
Ironruby-core at rubyforge.org<mailto:Ironruby-core at rubyforge.org>
http://rubyforge.org/mailman/listinfo/ironruby-core


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090325/59673084/attachment-0001.html>


More information about the Ironruby-core mailing list