[Ironruby-core] Confused - trying to run the specs

Jim Deville jdeville at microsoft.com
Tue Mar 24 19:32:51 EDT 2009

Just FYI, setting HOME after dev.bat should work fine. Dev.bat has detection logic. However, this won't matter after Shri's changes.


-----Original Message-----
From: Shri Borde <Shri.Borde at microsoft.com>
Sent: March 24, 2009 4:29 PM
To: Shri Borde <Shri.Borde at microsoft.com>; ironruby-core at rubyforge.org <ironruby-core at rubyforge.org>
Subject: Re: [Ironruby-core] Confused - trying to run the specs

Btw, HOME should be set to %USERPROFILE% (something like c:\Users\janedoe) for those who do not know what the value should look like.

From: Shri Borde
Sent: Tuesday, March 24, 2009 4:09 PM
To: ironruby-core
Subject: RE: [Ironruby-core] Confused - trying to run the specs

This does seem to be an issue with HOME not being set which Adam Khatava was also running into. Can you try setting HOME before running dev.bat? Dev.bat copies default.mspec to the HOME folder allowing the “mspec ci” command to know where to find the tests. So setting HOME after running dev.bat will *not* work.

I have a change for dev.bat to set HOME if it is not set already. If you could confirm that setting HOME before running dev.bat works, then I will know that my change is actually the right fix for your problem.

Tags are a way to disable tests. Browsing the ironruby-tags folder will tell you what does not work. See http://rubyspec.org/wiki/mspec/Mspec-tag for some info.


From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Thibaut Barrère
Sent: Tuesday, March 24, 2009 2:54 PM
To: ironruby-core
Subject: [Ironruby-core] Confused - trying to run the specs


I'm having a closer look at the source in order to attempt some work around system and IO popen.

I pulled the code, ran dev.bat etc. The build runs fine.

Now I'm trying to run the specs and something must be not quite right - or I'm not invoking the right modjo. Maybe some confusion with some existing install on the system, I'm not sure.

I've tried (U: is my github root):

U:\>mspec ci core\kernel\system
ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

Finished in 0.000000 seconds

0 files, 0 examples, 0 expectations, 0 failures, 0 errors
also tried:

U:\Merlin\External\Languages\IronRuby\mspec>mspec :core
U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `exec': No such file or directory - U:\Merlin\Main\Test\Scripts\ir.cmd (Errno::ENOENT)
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/commands/mspec.rb:150:in `run'
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/lib/mspec/utils/script.rb:203:in `main'
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/bin/mspec:7

I have no HOME var set. I tried setting it but it doesn't seem to change anything currently.

So any hint will help me go further here (I'll continue diving in here). Are there some steps I should carry out ?

As well, is there an explanation of what "tags" are for ? Are these some way to track the specs that aren't passing ?


-- Thibaut

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090324/811f4977/attachment.html>

More information about the Ironruby-core mailing list