[Ironruby-core] Confused - trying to run the specs

Thibaut Barrère thibaut.barrere at gmail.com
Tue Mar 24 17:53:58 EDT 2009

I'm having a closer look at the source in order to attempt some work around
system and IO popen.

I pulled the code, ran dev.bat etc. The build runs fine.

Now I'm trying to run the specs and something must be not quite right - or
I'm not invoking the right modjo. Maybe some confusion with some existing
install on the system, I'm not sure.

I've tried (U: is my github root):

U:\>mspec ci core\kernel\system
ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]

Finished in 0.000000 seconds

0 files, 0 examples, 0 expectations, 0 failures, 0 errors
also tried:

U:\Merlin\External\Languages\IronRuby\mspec>mspec :core
`exec': No such file or directory - U:\Merlin\Main\Test\Scripts\ir.cmd
        from U:/Merlin/External/Languages/IronRuby/mspec/mspec/bin/mspec:7

I have no HOME var set. I tried setting it but it doesn't seem to change
anything currently.

So any hint will help me go further here (I'll continue diving in here). Are
there some steps I should carry out ?

As well, is there an explanation of what "tags" are for ? Are these some way
to track the specs that aren't passing ?


-- Thibaut
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090324/a6e9404f/attachment.html>

More information about the Ironruby-core mailing list