[Ironruby-core] More WCF fail

Orion Edwards orion.edwards at gmail.com
Wed Mar 11 19:43:58 EDT 2009

Had time to get back to the WCF stuff: Here's the latest
class MyService
include IWcfContract

def ping(x)

uri = Uri.new "http://localhost:8700/MyService"
binding = WSHttpBinding.new
host = ServiceHost.new MyService
host.add_service_endpoint(IWcfContract.to_clr_type, binding, uri);

=> Now raises the following error (new and different from last time,

*The contract name 'IWcfContract' could not be found in the list of
contracts implemented by the service 'IronRuby.Builtins.RubyClass'.*
I also tried creating an abstract C# class as follows:

public abstract class WcfContractClass : IWcfContract
public abstract string Ping(string input);

and then having the ruby class do this:

class MyService < WcfContractClass

however the same error occurs. Still running the dlr nightly v12211 build...

Any ideas?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090312/86701314/attachment.html>

More information about the Ironruby-core mailing list