[Ironruby-core] possible problem on mono

Ivan Porto Carrero ivan at flanders.co.nz
Wed Mar 4 02:18:43 EST 2009


You can get the same behaviour by requiring rubygems I believe.

When I get back from work tonight I'll try to track down why this is
happening. I had it on my to-do list for a while now.

On Wed, Mar 4, 2009 at 7:39 AM, Rafael Rosa <lists at ruby-forum.com> wrote:

> Hi,
>
> Yes, I tried to build from source, but had a lot of problems and then I
> found these builds. Calling igems gives the same error Ivan had
> reported, here a fresh result:
>
> ~/Projetos : igem list --debug
> ERROR:  While executing gem ... (System::NullReferenceException)
>    Object reference not set to an instance of an object
>  IronRuby.Libraries:0:in `TryFlattenArray'
>  :0:in `flatten!'
>   mscorlib:0:in `CallSite.Target'
>   gem_runner.rb:25:in `run'
>   mscorlib:0:in `CallSite.Target'
>  igem:0
>
>
> If I try to call just "igem" it shows the help, no problem, but if I try
> to run "igem list" or "igem install any_gem" it shows the error above
> adding the --debug directive, and shows just the first two lines of the
> error if run without it.
>
> Hope it helps.
>
> Cheers,
> Rafael
> www.rafaelrosafu.com
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090304/6413528f/attachment.html>


More information about the Ironruby-core mailing list