[Ironruby-core] Issue with accents (UTF-8) - is it supposed to work ?

Ivan Porto Carrero ivan at flanders.co.nz
Tue Mar 3 09:57:48 EST 2009


No not a mono related issue. I get the same results when i run your sample
on windows with MS.NET
It must be an encoding thing. When I set the $KCODE to "UTF-8" it still has
the same behavior which is weird I guess :)


On Tue, Mar 3, 2009 at 3:35 PM, Thibaut Barrère
<thibaut.barrere at gmail.com>wrote:

> Hi,
>
> > not sure if it's an oddity in my code, a bug or non-implemented feature
> in
> > IronRuby or Mono - so I'm reporting it here. When using accents inside
> > strings ("Barrère") that I pass to either buttons or datagridviews, they
> > translate into "BarrA¨re". Here's a sample (also available on github):
>
> Bumping this one - do you have some idea of what's happening there ?
> Is it a mono related issue ?
>
> -- Thibaut
>
> > Hi,
> > not sure if it's an oddity in my code, a bug or non-implemented feature
> in
> > IronRuby or Mono - so I'm reporting it here. When using accents inside
> > strings ("Barrère") that I pass to either buttons or datagridviews, they
> > translate into "BarrA¨re". Here's a sample (also available on github):
> >
> > form = Magic.build do
> >   form(:text => "DataGridView sample", :width => 800, :height => 600) do
> >     # nifty - current Magic.build makes it possible to reuse the control
> > that has been added
> >     @grid = data_grid_view :dock => DockStyle.fill
> >     @grid.column_count = 2
> >     @grid.columns[0].name = "First name"
> >     @grid.columns[1].name = "Last name"
> >
> >     @grid.rows.add("Thibaut","Barrère") # using my name with its nasty
> > accent - utf-8 ?
> >   end
> > end
> >
> > After editing the datagridview, I noticed a log on stdout from mono:
> > 009-03-01 11:48:36.927 mono[5512:10b] WARNING:
> > CFSTR("Barr\37777777703\37777777603\37777777702\37777777650re") has non-7
> > bit chars, interpreting using MacOS Roman encoding for now, but this will
> > change. Please eliminate usages of non-7 bit chars (including escaped
> > characters above \177 octal) in CFSTR().
> > So I guess the issue probably boils down to non-MacOS Roman support in
> Mono.
> > What do you think ?
> > -- Thibaut
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090303/fdad7ceb/attachment.html>


More information about the Ironruby-core mailing list