[Ironruby-core] Where is open-uri and why it does not work?

Mohammad Azam lists at ruby-forum.com
Mon Jun 22 11:53:24 EDT 2009


Nope it does not work:

Here is the code:

require 'libs/System.Windows.Forms'
require 'libs/System.Drawing'
require 'libs/open-uri'

The libs folder contains uri.rb which is taken from

C:\ironruby\ironruby\Merlin\External.LCA_RESTRICTED\Languages\Ruby\ruby-1.8.6p287\lib\ruby\1.8

folder.

And here is the error:

C:\IronRubyProjects\IronRubyTaskListApplication>ir rss_reader_form.rb
:0:in `require': no such file to load -- uri (LoadError)
        from ./libs/open-uri.rb:1
        from rss_reader_form.rb:3
        from :0:in `require'





-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list