[Ironruby-core] IR 0.6.0 error loading a c# class

Ivan Porto Carrero ivan at flanders.co.nz
Wed Jul 8 06:44:14 EDT 2009


Could you share the code that is in the assemblies? or at least show the
namespaces etc?
---
Met vriendelijke groeten - Best regards - Salutations
Ivan Porto Carrero
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim
Author of IronRuby in Action (http://manning.com/carrero)



On Wed, Jul 8, 2009 at 6:44 AM, Mario A Chavez <mario.chavez at gmail.com>wrote:

> Hi;
> I have a custom C# Assembly1 which have interface ISomething and a C#
> Assembly2 which have class Something, and this class implements the
> interface like:
>
> public class Something : ISomething { }
>
> Using iirb I try to create an instace of that class but it complains about
> the class not being defined, I do use iirb as follow:
>
> requiere 'mscorlib'
> requiere 'System'
>
> require File.dirname(__FILE__) + '/build/assembly1.dll'
> require File.dirname(__FILE__) + '/build/assembly2.dll'
>
> include Assembly1
> include Assembly2
>
> @s = Something.new
> <-- Here it fails telling me that the class is not defined, but if I remove
> the code that implements the interface, it just works fine. My guess is that
> somehow is not resolving the interface, but I'm not sure how can I fix this.
>
> Thanks
>
>  Mario Alberto Chávez
> mario.chavez at gmail.com
> http://mario-chavez.blogspot.com/
>
>
>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090708/02fe3420/attachment.html>


More information about the Ironruby-core mailing list