[Ironruby-core] ERB

Tomas Matousek Tomas.Matousek at microsoft.com
Thu Jan 29 18:37:10 EST 2009

There should be a line in ir.exe.config that says something like:

      <set language="Ruby" option="LibraryPaths" value="..\..\Languages\Ruby\libs\;..\..\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\site_ruby\1.8\;..\..\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\site_ruby\;..\..\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\1.8\" />

These paths need to point to your MRI installation.


-----Original Message-----
From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Paul Wheeler
Sent: Thursday, January 29, 2009 2:01 PM
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] ERB

I playing with using ERB in IronRuby and having a little problem. The
code below works fine with Ruby:

require 'erb'
puts ERB.new('hello world').result

but in IronRuby I get this error:

IronRuby.Libraries:0:in `require': no such file to load -- erb
        from :0

Now if I change the require to this it works:

require 'C:\ruby\lib\ruby\1.8\erb.rb'
puts ERB.new('hello world').result

I assume my IronRuby config is wrong but how do I fix it?
Posted via http://www.ruby-forum.com/.
Ironruby-core mailing list
Ironruby-core at rubyforge.org

More information about the Ironruby-core mailing list