[Ironruby-core] possible problem on mono

Ivan Porto Carrero ivan at flanders.co.nz
Sat Feb 21 15:42:07 EST 2009


I'll try but i'm just moving into a new flat so it may take a few days
before I get some actual pc time
---
Met vriendelijke groeten - Best regards - Salutations
Ivan Porto Carrero
GSM: +32.486.787.582
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim



On Fri, Feb 20, 2009 at 5:59 PM, Tomas Matousek <
Tomas.Matousek at microsoft.com> wrote:

>  Could you try to narrow it down to a simple repro? What parameters are
> passed to "flatten!" that make it fail? (You may want to run it with –D to
> get full stack information, although it will be slower).
>
>
>
> Tomas
>
>
>
> *From:* ironruby-core-bounces at rubyforge.org [mailto:
> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Ivan Porto Carrero
> *Sent:* Friday, February 20, 2009 12:31 AM
> *To:* ironruby-core
> *Subject:* [Ironruby-core] possible problem on mono
>
>
>
> Hi
>
> When I try to run the igem script on mono it always comes back with a
> NullReferenceException.
>
> igem list --debug --backtrace
> ERROR:  While executing gem ... (System::NullReferenceException)
>     Object reference not set to an instance of an object
>     IronRuby.Libraries:0:in `TryFlattenArray'
>     :0:in `flatten!'
>     mscorlib:0:in `_stub_$2591'
>     gem_runner.rb:25:in `run'
>     mscorlib:0:in `_stub_$2495'
>     igem:0
>
> Is this known or should I add it to the bugs?
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090221/79caacff/attachment.html>


More information about the Ironruby-core mailing list