[Ironruby-core] Incorrect library paths in App.Config

Pete Bacon Darwin bacondarwin at googlemail.com
Fri Feb 13 09:13:13 EST 2009


Hi,

 

I just noticed that the App.Config that is generated in an in Unsigned build
of IronRuby (i.e. rake compile) contains incorrect library paths.  When I
tried to run rake mspec:core it failed to require 'fileutils'.

 

Currently (Git commit 6855c7c41ee2...) has the following in
Merlin/Main/Config/Unsigned/App.Config:

 

<set language="Ruby" option="LibraryPaths"
value="..\..\Languages\Ruby\libs\;..\..\..\External\Languages\Ruby\ruby-1.8.
6\lib\ruby\site_ruby\1.8\;..\..\..\External\Languages\Ruby\ruby-1.8.6\lib\ru
by\site_ruby\;..\..\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\1.8\" />

 

But the repository has the following folder layout:

 

Merlin/External/Languages/Ruby/redist-libs/ruby/1.8

And

Merlin/External/Languages/Ruby/redist-libs/ruby/site_ruby

 

So therefore this file should look like this:

 

<set language='Ruby' option='LibraryPaths'
value='..\..\Languages\Ruby\libs;..\..\..\External\Languages\Ruby\redist-lib
s\ruby\site_ruby\1.8;..\..\..\External\Languages\Ruby\redist-libs\ruby\site_
ruby;..\..\..\External\Languages\Ruby\redist-libs\ruby\1.8'/>

 

I thought I must be wrong since this should have been picked up already but
then I guess that most people who are building IR at the moment are either
inside MSFT (and using signed builds) or running on Mono and having to
rewrite this file anyway.

 

Am I right here?

 

Pete

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090213/3b0b79a4/attachment.html>


More information about the Ironruby-core mailing list