[Ironruby-core] cannot initialize Form with IronRuby

Ivan Porto Carrero ivan at flanders.co.nz
Sun Feb 8 16:29:20 EST 2009


I just compiled the ironruby version from github with rake and for me the
following code works.

require "System.Windows.Forms, Version=2.0.0.0, Culture=neutral,
PublicKeyToken=b77a5c561934e089"
Form = System::Windows::Forms::Form
f = Form.new
f.show



On Sun, Feb 8, 2009 at 7:54 PM, Meinrad Recheis
<meinrad.recheis at gmail.com>wrote:

> IronRuby 1.0.0.0 on .NET 2.0.50727.1433
> Copyright (c) Microsoft Corporation. All rights reserved.
>
> >>> require "System.Windows.Forms, Version=2.0.0.0, Culture=neutral,
> PublicKeyTo
> ken=b77a5c561934e089"
> => true
> >>> Form = System::Windows::Forms::Form
> => System::Windows::Forms::Form
> >>> f=Form.new
> => #<System::Windows::Forms::Form:0x000005c>
> >>> f.Show()
> :0: wrong number of arguments (2 for 3) (ArgumentError)
>
> >>> f.method( :Show).arity
> => 0
> >>>
>
> This is the latest daily DLR build on codeplex from 2009 Feb 1 at
> 9:36 PM. I read, that with older versions winforms interop has already been
> working.
>
>
> -- henon
>
>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090208/145697e9/attachment.html>


More information about the Ironruby-core mailing list