[Ironruby-core] IronRubyMvc Problem with new Dlls

Ivan Porto Carrero ivan at flanders.co.nz
Fri Aug 14 06:21:18 EDT 2009


which ironruby mvc version are you using?The one I have in my github account
should work with ironruby 0.9


---
Met vriendelijke groeten - Best regards - Salutations
Ivan Porto Carrero
Blog: http://flanders.co.nz
Twitter: http://twitter.com/casualjim
Author of IronRuby in Action (http://manning.com/carrero)



On Fri, Aug 14, 2009 at 9:42 AM, Shay Friedman <shay.friedman at gmail.com>wrote:

> Hi,
>
> I've pulled the code of the IronRubyMvc project and compiled - the sample
> project worked well.
> I noticed that the IronRubyMvc project references were using the IronRuby
> 0.4 version. I replaced that to the 0.9 version that I had. After that, the
> sample project doesn't load anymore and fails with the next error:
>
> Server Error in '/' Application.Method not found: 'Void
> Microsoft.Scripting.Runtime.Scope.SetVariable(Microsoft.Scripting.SymbolId,
> System.Object)'.Line 537: internal void SetGlobalConstant(string/*!*/
> name, object value) {
> Line 538: _globalScope.SetVariable(SymbolTable.StringToId(name), value);
> Line 539: }
> In Merlin\Main\Languages\Ruby\Ruby\Runtime\RubyContext.cs
>
> Is it something on my end or does the project need some modifications to
> work with the new version?
>
> Thanks!
> Shay.
>
> ----------------------------
> Shay Friedman
> http://www.IronShay.com <http://www.ironshay.com/>
> Follow me: http://twitter.com/ironshay
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090814/f750ffdd/attachment.html>


More information about the Ironruby-core mailing list