[Ironruby-core] Problems running irtests.bat

Ryan Riley ryan.riley at panesofglass.org
Thu Aug 6 17:44:12 EDT 2009


That's a good point, and I forgot to add the ".bat" to mspec in my original
email. And of course, that fixes the problem. :) I removed the full path and
just added ".bat" and I can run the tests just fine.


Ryan Riley
ryan.riley at panesofglass.org
http://panesofglass.org/
http://wizardsofsmart.net/


On Thu, Aug 6, 2009 at 4:24 PM, Shri Borde <Shri.Borde at microsoft.com> wrote:

>  To add to that, running “mspec ci –fd :lang” worked from the command
> line. When irtests.rb tried to call system() with that exact same command
> line (we verified that it was the exact same value), system() failed
> returning false. Doing system(“where mspec”) from within irtests.rb did show
> the correct version of (mspec and) mspec.bat, which implies that the value
> of PATH of the “rake” process was also correct.
>
>
>
> Ryan, one thought just occurred to me. What happens if you do “mspec_base
> = "mspec.bat ci -fd"””? ie. add “.bat”. I wonder if system(“mspec ci –fd”)
> is trying to run the “mspec” Ruby file.
>
>
>
> In either case, using the full path sounds like a good idea anyway.
>
>
>
> *From:* ironruby-core-bounces at rubyforge.org [mailto:
> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Ryan Riley
> *Sent:* Thursday, August 06, 2009 2:15 PM
> *To:* ironruby-core at rubyforge.org
> *Subject:* [Ironruby-core] Problems running irtests.bat
>
>
>
> During our pair programming session today, Shri, Kevin, and I walked
> through some issues running RubySpecs from irtests and rake test:spec_a.
> The issue appears to have something to do with the path, as we tried
> numerous usages of system with various commands. We finally solved it by
> adding mspec_path = "#{root}\\..\\
> External.LCA_RESTRICTED\\Languages\\IronRuby\\mspec\\mspec\\bin" and
> including mspec_path at the beginning of mspec_base =
> "#{mspec_path}\\mspec.bat ci -fd", effectively hard-coding the path.
>
>
>
> I believe Kevin also had this problem, so if anyone else is having the
> problem, you can try that. After making those changes, everything ran fine
> for me.
>
>
> Ryan Riley
> ryan.riley at panesofglass.org
> http://panesofglass.org/
> http://wizardsofsmart.net/
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090806/122ab7cd/attachment.html>


More information about the Ironruby-core mailing list