[Ironruby-core] defined?(xxx) behaves differently when called from Silverlight

Jimmy Schementi Jimmy.Schementi at microsoft.com
Thu Apr 2 20:59:47 EDT 2009

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Thibaut Barrère
Sent: Thursday, April 02, 2009 3:44 PM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] defined?(xxx) behaves differently when called from Silverlight

The folder SL is installed into is the version; if you're using SL2 it should be C:\Program Files\Microsoft Silverlight\2.0.40115.0\. SL3 Beta is C:\Program Files\Microsoft Silverlight\3.0.40307.0\.
I'm testing this from my Mac. I'll be searching for the files using find.


Unzip that and double-click on the index.html file. The first line of app.xap is defined?(System::Windows::Forms), and works fine. It also works in the console. Let me know what happens for you.

Clicking on index.html shows a welcome message and the ironruby console, so it doesn't seem to bang.

Editing has some weird behaviour: when I type (, defined? gets erased. Maybe totally unrelated, but this mean I can't test in the console.

I'm a bit puzzled as why it fails. I'll try to find some extra time to investigate - may be related to the fact that I'm using Chiron on Mac ?

No idea what's happening for the moment.

Thanks for the repro, Jimmy.

-- Thibaut

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20090403/a56d9cf8/attachment.html>

More information about the Ironruby-core mailing list